Registrieren Hilfe Suche Mitgliederliste Wer ist online? Einloggen
Willkommen bei Tritanium Community! Falls dies Ihr erster Besuch hier ist, lesen Sie sich bitte die Hilfe mit den häufigsten Fragen und ausführlichen Erklärungen durch! Falls Sie an den Diskussionen teilnehmen wollen, sollten Sie sich registrieren oder, falls Sie das schon getan haben, sich einloggen. Wir wünschen Ihnen viel Spaß!

Tritanium Community » Tritanium Bulletin Board 1 » Installationsprobleme » ERROR: Module Language does not exists!

Seiten (2) [1 | 2   »] Neue Antwort erstellenNeues Thema erstellen

Autor Thema: ERROR: Module Language does not exists!
Welthafen
Lernt noch alles kennen

ID # 2998



ERROR: Module Language does not exists!
cornelius.heinze@gmail.com
Hallo,

ich versuche das Update von 1.2.3 auf 1.5.4. Ich habe erst 1.5.3 gepatcht und damit auf 1.5.4. upgedatet. Danach alle Schritte gemäß readme ausgeführt. Jetzt scheitere ich beim Aufrufen des Forums an der Meldung: "ERROR: Module Language does not exists!"
Im Language-Ordner findet sich der Ordner "de-DE" aber.

Oder war der Fehler, dass ich erst den 1.5.4-Patch eingefügt habe, anstatt zunächst nur auf 1.5.3 zu updaten?

Link: http://www.nirvana-eimsbuettel-united.de/tbbforum/

(Sorry, der Beitrag ist falsch im "Bugs"-Forum, ist eigentlich ein Installationsproblem)


Dieser Beitrag wurde schon 1 Mal bearbeitet, zuletzt von Welthafen.
Geposted: 08.05.2011 16:06
Chrissyx
Supermoderator

ID # 2285



Re: ERROR: Module Language does not exists!
E-Mail schicken
Die Reihenfolge von Update und Patch sollte egal sein. Die Fehlermeldung bezieht sich auch nicht auf den Order mit den Sprachdateien, sondern dass deine modules/Language.php nicht existiert. Hast Du sie beim Upload vergessen? ;)

-----------
Tritanium Scripts developer
Filebased rulez
Geposted: 08.05.2011 19:12
Chrissyx
Supermoderator

ID # 2285



Re: ERROR: Module Language does not exists!
E-Mail schicken
Zitat von Welthafen:
Also, hier die ganze Geschichte:

tbb1.2.3 lief prima bis zum serverseitigen php-Upgrade vor ungefähr einem Jahr (auf 5.2?). Seitdem funktionierte das Forum zwar noch, aber es kamen immer wieder mal Fehlermeldungen.

Nach dem Serverupgrade auf 5.3 ging gar nichts mehr, nur noch Fehlermeldungen. Der Provider teilte mir mit, ja, das liege am Upgrade.

Ich (Laie) habe mehrfach versucht, 1.2.3 auf 1.5.4 zu aktualisieren, aber nur mit Teilerfolgen: Im Beitragstext komische Sonderzeichen, Fehlermeldungen en masse, Verlust des individuellen Boardaufbaus, und dann konnte ich mich mehrmals nach dem Ausloggen nicht wieder einloggen.

Dann mal der Reihe nach:
  • Was für Sonderzeichen?
  • Was für Fehlermeldungen?
  • Inwiefern Verlust? Hast Du irgendwelche Hacks eingebaut oder nur die CSS modifiziert? Die kannst Du nämlich ohne Probleme weiter benutzen, bei Hacks wird's schon knifflig.
  • Nicht einloggen könnte eine Folgerscheinung anderer Fehler sein.
Ich hoffe Du hast noch ein Backup vom 1.2.3er oder zumindest die Ordner mit den ganzen Daten gesichert (foren, members, polls usw.), dann kannst Du nochmal ein Update auf 1.5 probieren. Wenn Du ICQ hast, kann ich dir auch quasi live helfen. :)

-----------
Tritanium Scripts developer
Filebased rulez
Geposted: 16.05.2011 23:37
Chrissyx
Supermoderator

ID # 2285



Re: ERROR: Module Language does not exists!
E-Mail schicken
Zitat von Welthafen:
Erstmal Danke für die bisherige Hilfe und die schnelle Reaktion. Das 1.5.4er Forum ist unter http://www.nirvana-eimsbuettel-united.de/tbb154 zu finden, da sind auch die Fehlermeldungen zu sehen. Hacks gibt's keine, nur eine eigene CSS.
Erstmal gute Nacht, melde mich übermorgen wieder.


Ohne mich zu registrieren sehe ich dort keine Fehler - nur das Daten fehlen. Hast Du die modules/Config.php bearbeitet? Wie sieht deine vars/settings.var aus? Hat sie exakt 75 Zeilen?

-----------
Tritanium Scripts developer
Filebased rulez
Geposted: 16.05.2011 23:54
Welthafen
Lernt noch alles kennen

ID # 2998



Re: ERROR: Module Language does not exists!
cornelius.heinze@gmail.com
Die modules/config.php habe ich nicht angefasst, und in der vars/settings.var habe ich eben nochmal nachgezählt: Jawohl, 75 Zeilen.

Beispiele für Fehlermeldungen, die für registrierte User erscheinen:

Beim Aufrufen eines Threads erscheint der Thread und darüber - einmal oder auch mehrmals - die Meldung:

Warning: implode() [function.implode]: Invalid arguments passed in /home/w15998/web/public_html/tbb154/core/FunctionsBasic.php on line 537

Nach Klick auf den "Antwort"-Button erscheint zwar das Antwortfeld wie gewünscht, darüber aber:

Warning: array_fill() [function.array-fill]: Number of elements must be positive in /home/w15998/web/public_html/tbb154/core/FunctionsBasic.php on line 519

Komische Sonderzeichen:
ä statt ä
ö statt ö
fü statt ü
ß statt ß
Geposted: 17.05.2011 22:09
Chrissyx
Supermoderator

ID # 2285



Re: ERROR: Module Language does not exists!
E-Mail schicken
Beide Fehlermeldungen gehen darauf zurück, dass etwas mit den Config-Werten nicht stimmt. Kannst Du deine settings.var mal sichern und dann in der Administration Einstellungen zurücksetzen ausführen? Werden danach immer noch diese Fehler angezeigt?

-----------
Tritanium Scripts developer
Filebased rulez
Geposted: 18.05.2011 00:17
Chrissyx
Supermoderator

ID # 2285



Re: ERROR: Module Language does not exists!
E-Mail schicken
Zitat von Welthafen:
Zitat von Chrissyx:
Zitat von Welthafen:
Zitat von Chrissyx:
Hi Conny,

ich hab mich grad mal im 1.5.4er umgesehen und der settings.var fehlten ein paar Einstellungen. Hauptsächlich Rangbezeichner, Anzahl der Sterne und ein paar Daten zu Forum und Seite. Ich hab dort erstmal Standardwerte eingetragen. Außerdem war die ranks.var komplett leer, so dass ich auch hier die originale Datei hochgeladen habe. Probier mal aus, ob jetzt alles funktioniert. :)

mfg Chris


Hurra, es klappt! Dankedankedanke!

Jetzt brauche ich nur noch ein paar Template-Tipps. Da alle
Forumteilnehmer sich persönlich kennen, brauchen wir etliche derzeit
sichtbare Informationen nicht, und zwar:

In der Forenübersicht:
Die Moderatorenspalte rechts

In der Themenübersicht:
Die Ordnerspalte ganz links ("hot";)

In der Beitragsübersicht:
Alle Statusmeldungen, Gruppenzugehörigkeiten, Sterne und ID-Nummern
(die Namen sollen natürlich bleiben).
Die Fußzeile unter jedem Beitrag (Beträge, Mitglied, IP-Adresse).

Wie kann ich diese Infos zum Verschwinden bringen?


Hi Conny,

ich würde vorschlagen, alle nicht benötigten Sachen einfach auszukommentieren. Das geht direkt auf Template-Ebene mit {* *}, also
{* Dies ist ein Kommentar und erscheint nicht in der XHTML-Seite *}
Wenn Du unsicher bist, kann ich es auch per FTP machen. Bedenke aber, dass dies nach jedem Update erneut gemacht werden muss.
Bei den Rängen würde sich zu dem anbieten, nur einen ab 0 Beiträge zu machen und ihn "Mitglied", "Benutzer" oder so zu nennen.

Ansonsten würde ich gerne den E-Mail-Verkehr ins Tritanium-Forum verschieben und dort weiter schreiben, so dass andere mit ähnlichen Problemen die Lösung auch wissen und weiter verfolgen können. Ist das OK?

Ich bin in der Tat unsicher, und wenn Du das machen kannst, würde es mich freuen.


Der Schriftwechsel gehört in's Forum, klar. Kein Einwand.


Ich hab alles unerwünschte soweit auskommentiert. Guck dir mal genau an, was geändert wurde, damit Du zukünftig bei Bedarf sowas selber machen kannst. ;)

-----------
Tritanium Scripts developer
Filebased rulez
Geposted: 19.05.2011 19:43
Welthafen
Lernt noch alles kennen

ID # 2998



Re: ERROR: Module Language does not exists!
cornelius.heinze@gmail.com
Huch! Alle Nullen fehlen!
Was tun?
Geposted: 20.05.2011 10:51
Chrissyx
Supermoderator

ID # 2285



Re: ERROR: Module Language does not exists!
E-Mail schicken
Was für Nullen? :confused:

-----------
Tritanium Scripts developer
Filebased rulez
Geposted: 20.05.2011 12:06
Welthafen
Lernt noch alles kennen

ID # 2998



Re: ERROR: Module Language does not exists!
cornelius.heinze@gmail.com
Die Ziffer Null wird im Forum nicht dargestellt.
Wenn ich testhalber in die Antwortbox eingebe: 10203040
Dann bekomme ich im Forum zu lesen: 1234
Ist im ganzen Forum so.
Geposted: 20.05.2011 13:22

Seiten (2) [1 | 2   »] Neue Antwort erstellenNeues Thema erstellen
Tritanium Bulletin Board 2
© Tritanium Scripts